User Tag List

Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 59
  1. #31
    F douche bags
    Join Date
    Nov 2012
    Name
    derk
    Location
    Stanton (Cerritos and Knott)
    Posts
    3,194
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Tommy Ngo View Post
    Do you have some pictures of what you had done?
    I'll have to snap it later. but I put back whatever I removed for cleaning. only thing is splattering from where the head meets the engine or carb. why does thebfix it reads say to loosen the glow plug? how is loosening the glow suppose to help. when it fired yesterday I had it slightly loose and gas was putting out of there. more fine then splattering.
    Last edited by cowboycove; 04-13-2016 at 05:01 AM.
    Fraggers anonymous -hi, my name is derk. And I'm a fragaholic

  2. #32
    F douche bags
    Join Date
    Nov 2012
    Name
    derk
    Location
    Stanton (Cerritos and Knott)
    Posts
    3,194
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Tommy Ngo View Post
    Do you have some pictures of what you had done?
    I removed the cooling head from I believe the engine.head is blue and the aluminum is where it meets. I removed it again today to make sure its clean and it still seems to have a very ligt splatter.
    I'm not sure how often I am suppose to charge this but it says servo whatever that is. I charged it once when I got it. But the light always turned on so I never thought I needed to charge again until it was dead
    I am beyond frustrated. Im not sure if i should just take it to a professional so I Dont f%-+ more **** up. But I barely spun this screw to try and adjust the carb and it came off. I couldn't put it back on. It had an o-ring. Even without the o-ring I couldn't get it back on. The threading was stripped or something. I also couldn't get the flow plug to glow again. Not sure why. But it did just once yesterday before it fired for the few seconds. I out in a new one and it still didn't glow.


    Any idea how much hobby shops normally charge to service and fix sh!t?
    Fraggers anonymous -hi, my name is derk. And I'm a fragaholic

  3. #33
    Registered Member
    Join Date
    Jan 2014
    Name
    Tommy
    Location
    anaheim
    Posts
    339
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by cowboycove View Post
    I removed the cooling head from I believe the engine.head is blue and the aluminum is where it meets. I removed it again today to make sure its clean and it still seems to have a very ligt splatter.
    I'm not sure how often I am suppose to charge this but it says servo whatever that is. I charged it once when I got it. But the light always turned on so I never thought I needed to charge again until it was dead
    I am beyond frustrated. Im not sure if i should just take it to a professional so I Dont f%-+ more **** up. But I barely spun this screw to try and adjust the carb and it came off. I couldn't put it back on. It had an o-ring. Even without the o-ring I couldn't get it back on. The threading was stripped or something. I also couldn't get the flow plug to glow again. Not sure why. But it did just once yesterday before it fired for the few seconds. I out in a new one and it still didn't glow.


    Any idea how much hobby shops normally charge to service and fix sh!t?
    Dang! The RC is filthy. The guy you brought it from didn't clean the rc before he sold it to you?

    From what i remember there should be any gasket from the engine n cooling fins. Check to see if your piston rod is damaged or not.

    The servo is not the problem. The servo is there to communicate with your controller. It got nothing to do with the engine not firing up.

    I believe it's around $40/hr for repair service. I would just take it in to have it check out to see what wrong with it and if it's worth fixing.

  4. #34
    Registered Member
    Join Date
    Jan 2014
    Name
    Tommy
    Location
    anaheim
    Posts
    339
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Also if you cover the exhaust opening with you finger n push on on the ez start wand, sometime the engine will fire up.


    Sent from my iPhone using Tapatalk

  5. #35
    F douche bags
    Join Date
    Nov 2012
    Name
    derk
    Location
    Stanton (Cerritos and Knott)
    Posts
    3,194
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Tommy Ngo View Post
    Dang! The RC is filthy. The guy you brought it from didn't clean the rc before he sold it to you?

    From what i remember there should be any gasket from the engine n cooling fins. Check to see if your piston rod is damaged or not.

    The servo is not the problem. The servo is there to communicate with your controller. It got nothing to do with the engine not firing up.

    I believe it's around $40/hr for repair service. I would just take it in to have it check out to see what wrong with it and if it's worth fixing.
    it was dirtier then that. lol. the piston was pumping when I took the head off. I'll just take it in to a shop soon. there's one near Knott's Berry farm I think. I can't imagine a ton of stuff being wrong with it since it was just a bad glow. but I wouldn't be surprised after I messed with all the sh!t that it won't be worth fixing. I assume that thing I can't put back on is going to have to be replaced. the carb is 30 on eBay.
    Fraggers anonymous -hi, my name is derk. And I'm a fragaholic

  6. #36
    F douche bags
    Join Date
    Nov 2012
    Name
    derk
    Location
    Stanton (Cerritos and Knott)
    Posts
    3,194
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Tommy Ngo View Post
    Also if you cover the exhaust opening with you finger n push on on the ez start wand, sometime the engine will fire up.


    Sent from my iPhone using Tapatalk
    I'll try that. and if I have to buy a new carb. should I just buy a used engine with it? I saw a rebuilt engine with new carb for 60. new piston and everything.
    Fraggers anonymous -hi, my name is derk. And I'm a fragaholic

  7. #37
    Registered Member
    Join Date
    Jan 2014
    Name
    Tommy
    Location
    anaheim
    Posts
    339
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by cowboycove View Post
    I'll try that. and if I have to buy a new carb. should I just buy a used engine with it? I saw a rebuilt engine with new carb for 60. new piston and everything.
    Good price

  8. #38
    Premium Member Fly5150's Avatar
    Join Date
    Sep 2012
    Name
    Matt
    Location
    lakewood
    Posts
    4,019
    Mentioned
    138 Post(s)
    Tagged
    6 Thread(s)

    Default

    Take it to a pro...and quit turning screws when you have no idea what they do. When I had gas R/C cars, they were always a pain...requiring constant tuning. I'm over it. Just picked up a brushless Traxxas Slash 4x4 ultimate with lipo. So easy, plug in the battery and run for like an hour.


    Sent from my iPhone using Tapatalk

  9. Likes cowboycove, gumbii liked this post
  10. #39
    Moderator solitude127's Avatar
    Join Date
    Apr 2010
    Name
    Mike
    Location
    Torrance
    Posts
    6,360
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)

    Default

    Quote Originally Posted by Fly5150 View Post
    Take it to a pro...and quit turning screws when you have no idea what they do.
    This is good advice. they can start you off in the right direction.
    60*30*20, 8x54 ATI Powermodule, ReefBrite XHO, ATB Elegance 200, Ecotech Vortechs, Apex Controls, WM Ecobak powered. 30G nano, MP10, Apex Jr, Ecotech Radion XR15

  11. Likes cowboycove liked this post
  12. #40
    Moderator solitude127's Avatar
    Join Date
    Apr 2010
    Name
    Mike
    Location
    Torrance
    Posts
    6,360
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)

    Default

    dang double post again. Here I come @Tangwich
    Last edited by solitude127; 04-14-2016 at 08:34 AM.
    60*30*20, 8x54 ATI Powermodule, ReefBrite XHO, ATB Elegance 200, Ecotech Vortechs, Apex Controls, WM Ecobak powered. 30G nano, MP10, Apex Jr, Ecotech Radion XR15

  13. Likes gumbii liked this post
  14. #41
    Premium Member lowbudget's Avatar
    Join Date
    Nov 2007
    Name
    LowBaller
    Location
    los angeles
    Posts
    21,677
    Mentioned
    270 Post(s)
    Tagged
    2 Thread(s)

    Default

    Quote Originally Posted by solitude127 View Post
    This is good advice. they can start you off in the right direction.
    holly batman double post
    Quote Originally Posted by lurking View Post
    He says your pictures suck
    Quote Originally Posted by wickedfish View Post
    Yep I love big wieners just like Schnitzel

  15. #42
    Resident Realogist Tangwich's Avatar
    Join Date
    May 2009
    Name
    Jesse
    Location
    Pasadena
    Posts
    10,478
    Mentioned
    331 Post(s)
    Tagged
    3 Thread(s)

    Default

    Quote Originally Posted by solitude127 View Post
    dang double post again. Here I come @Tangwich
    Someone must have turned off my double post button : (

  16. #43
    Premium Member lowbudget's Avatar
    Join Date
    Nov 2007
    Name
    LowBaller
    Location
    los angeles
    Posts
    21,677
    Mentioned
    270 Post(s)
    Tagged
    2 Thread(s)

    Default

    Quote Originally Posted by Tangwich View Post
    Someone must have turned off my double post button : (
    mine not working
    Quote Originally Posted by lurking View Post
    He says your pictures suck
    Quote Originally Posted by wickedfish View Post
    Yep I love big wieners just like Schnitzel

  17. Likes Tangwich liked this post
  18. #44
    send nudes
    Join Date
    Feb 2009
    Name
    gumbii garcia
    Location
    bell gardens
    Posts
    18,585
    Mentioned
    547 Post(s)
    Tagged
    11 Thread(s)

    Default

    Quote Originally Posted by Fly5150 View Post
    Take it to a pro...and quit turning screws when you have no idea what they do. When I had gas R/C cars, they were always a pain...requiring constant tuning. I'm over it. Just picked up a brushless Traxxas Slash 4x4 ultimate with lipo. So easy, plug in the battery and run for like an hour.


    Sent from my iPhone using Tapatalk
    how are brushless now...? a couple years back i used to make titanium roll cages for hard body Z in huntington beach... one time they gave us some electric RC and that ****** was crazy fast... but i remember it had replaceable brush heads... i can just imagine the torque from brushless motors... good lord...

    Quote Originally Posted by lurking View Post
    I like to think of it as you were loving on my pipes rather than working on them.
    Quote Originally Posted by MadMax View Post
    Hey man, as long as there aint no funky tongue action, I'm cool with it, LOL!
    Quote Originally Posted by Greaser9999 View Post
    Please do not send me nudes of u & Noah together

  19. #45
    Premium Member Fly5150's Avatar
    Join Date
    Sep 2012
    Name
    Matt
    Location
    lakewood
    Posts
    4,019
    Mentioned
    138 Post(s)
    Tagged
    6 Thread(s)

    Default

    Quote Originally Posted by gumbii View Post
    how are brushless now...? a couple years back i used to make titanium roll cages for hard body Z in huntington beach... one time they gave us some electric RC and that ****** was crazy fast... but i remember it had replaceable brush heads... i can just imagine the torque from brushless motors... good lord...
    60+ on a 2s lipo...fast enough.

 

 
Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •