User Tag List

Results 1 to 4 of 4

Thread: RO/DI trouble

  1. #1
    Registered Member
    Join Date
    Sep 2014
    Name
    Izabela
    Location
    san juan capistrano
    Posts
    123
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default RO/DI trouble

    I have some trouble with my RO system. I just put a new 0.5mic sediment filter, and then two 0.5mic carbon filters, next is the color changing DI resin. I have about 10 months old SPECTRAPURE SPECTRA SELECT PLUS 99 PERCENT REJECTION 90-GPD MEMBRANE.
    After putting in the new filter, the tds was 0, but not even 5 gal of water in a bucket and tds was back to 300ppm, my tap water is 308. What is wrong with my ro filter? Is the membrane bad already and it caused DI resin to go bad so fast. The DI resin already changed color to golden- brown. The water flow is rather fast. Should I get a new unit? Or how can I fix it?

  2. #2
    Premium Member
    Join Date
    Aug 2014
    Name
    Gus
    Location
    Valencia
    Posts
    366
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Do you have an idea of what the PSI going into the RO system is?

  3. #3
    Registered Member
    Join Date
    Sep 2014
    Name
    Izabela
    Location
    san juan capistrano
    Posts
    123
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    I don't, do you think too high PSI is an issue? How can I lower PSI?

  4. #4
    **** ELLIS AQUATICS **** JDEllis's Avatar
    Join Date
    Oct 2012
    Name
    Jayson - Owner @ Ellis Aquatics
    Location
    Compton, CA 90222
    Posts
    3,230
    Mentioned
    85 Post(s)
    Tagged
    3 Thread(s)

    Default

    Check your:
    1. PSI
    2. Make sure flow restricter is still in place and didn't fall out or get moved
    3. Do you have a flush valve and is it open?
    4. Is the TDS Meter hooked up correctly? Did it get wet/damaged?
    Ellis Aquatics
    the HIGHEST Quality, the LOWEST Prices


    See you soon...

    Facebook.com/ellisaquatics
    Follow on instagram @ellisaquatics

    562.822.6673

    180g (96x36x12) zoa/paly/acan frag tank: 3 kessil 360we, 4 - 2x54w t5/led combos, 180g custom sump (72x24x24), curve 9 skimmer

    180g (96x36x12) sps/lps/clam frag tank: (2) Ecotech Radion Gen 3 Pro, (2) AI Hydra 52s, 180g custom sump (72x24x24), curve 9 skimmer

    150g fish system (48x15x96) 7 section (6-10g and 1-33g section), 5x current usa true lumen led lights

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •