Is this normal?

Joined
Feb 10, 2011
Messages
575
Likes
2
Points
18
Location
Porter Ranch
#1
The glass on my tank literally grows a fine dusting of algae within 6 hours of cleaning it. If I want to keep my tank somewhat presentation ready I have to clean the glass everyday. My phosphates are about .05 and I have to dose nitrates to keep it at about 3-5ppm. Whats going on here? Whats been your experience?
 

joseserrano

Member
2020 Contributor
Joined
Nov 6, 2013
Messages
3,777
Likes
655
Points
83
Location
Santa Ana/Tustin
#2
You more than likely have an imbalance, stop dosing nitrate or phosphate. If you need more nutrients, feed foods. Look at your corals before you start experimenting with nutrient dosing
 

reefes pieces

Premium Member
Supporter
Joined
Oct 5, 2011
Messages
4,806
Likes
69
Points
48
Location
Placentia
#4
I had that for some time. I did a few things and now only scrape my tank once a week. For me it was biome or lack thereof. I dosed MB7 and Brightwell Razor simultaneously. My guess is that algae is consuming your nutrients instead of a diverse bacteria population.
 
Joined
Feb 10, 2011
Messages
575
Likes
2
Points
18
Location
Porter Ranch
#5
Thats the thing, I feed heavy, have a UV, have very little other algae growth on the rock work, corraline is growing well, and nutrients seem to be in-check. SPS, and LPS are all growing well too. Weekly water changes, dosing alk, cal, mag to proper levels. Is it just a phase of the tank? Only thing i can somewhat point too is the generic chinese light but coral growth is solid.
 

reefes pieces

Premium Member
Supporter
Joined
Oct 5, 2011
Messages
4,806
Likes
69
Points
48
Location
Placentia
#6
I run UV as well. probably just a phase and with time the more mature the tank gets the less of an issue that will be. I'd say give the Brightwell Razor a try. Worked wonders for me.
 

Latest posts

Top